Having trouble with installation


#1

Hello there,

I have a difficulty to install Monolith for Grasshpper. Once the installation process is done and I tried to access Monolith though its own icon,however, I always got an error message saying that Monolith has stopped working. Does anyone know a solution for this problem? Also, I wouldnt really see any icons shown on the Grasshopper interface. Would anyone please help me make it work? Thank you very much.

Best,

PH Chen


#2

Just to give a bit more information about my setup. Im using Rhino 64 bit SR5 with the Grasshopper version 0.90076


#3

Are you running Windows through Parallels? We’ve found that the program fails when running Parallels. Can you run Windows natively by running it through Bootcamp instead?


#4

Yes, it works now! Thanks!

I wonder if there is a tutorial explaining all the function of the Monolith components?


#5

Do you mean all of the Grasshopper components for Monolith? There is a user guide but that mainly cover the main application and doesn’t have much information (yet) for the plugins. My best advice is to look at the examples that are included with the installer. You should be able to find these in C:\Program Files\Monolith\Examples\Grasshopper. You can also download them from here. They have been pretty heavily annotated so hopefully this will give you a good start. Let us know if you have any additional questions. Cheers.


#6

I have windows 7 on a mac with bootcamp and it gets through installing monolith but fails on the visual C++ install. Do you have any suggestions. It is working great on my other computer which is using windows 10. thanks, jason


#7

Hi Jason. Can you try downloading the redistributable file directly: https://www.microsoft.com/en-us/download/details.aspx?id=49984 and see if that fixes your issue. If it does not, let us know and we’ll try to find a different solution. Thanks.


#8

Can’t open Monolith.I am on windows 8.1 64 bit.I thought it was Kaspersky but I have allowed the program to operate with Kaspersky so I think it is something else.any ideas?


#9

Hi hhal9000. Do you get any error messages or warnings? Did the visual C++ runtimes get installed when you ran the installer? You can download them directly and install just to be on the safe side: https://www.microsoft.com/en-us/download/details.aspx?id=49984. Are you running Windows on a Mac? If so, can you describe your configuration (ie. VMWare vs. Bootcamp vs. Parallels, etc).


#10

Hi Andrew.I’m running windows 8.1 on a PC not a mac and I’m not getting any error messages.Just installed the files and still nothing.


#11

@hhal9000… And you were definitely able to install the VC++ runtimes on your machine?


#12

Yes.They were installed


#13

Hello Adrew, i the have the same problem of Hal 9000.
During the installation of Monolith & Vc++everything was OK.
When Grasshopper loads the Monolith file it´s running, and in the component folders of Grasshopper the Monolith file appears, but i don´t be able to see the tab file of Monolith. Or maybe i missing the way to start running Monolith, sorry any idea? Thanks!


#14

Hi Andrew, I am a student at CCA. I was at the workshop. So the problems I had were. I wasn’t able to get the icons to show up in my grasshopper interface. I have an Asus running windows 8. Also, I wasn’t able to get the dot to move an object/shape in the standalone software itself. If you need any more specs let me know. Im really interested on this software. Thanks!!!


#15

guys,

when i am trying to open the monolith from my desktop “the porgram has stopped working window popuped” any help here

Problem Event Name: CLR20r3
Problem Signature 01: Monolith.exe
Problem Signature 02: 0.2.5879.24551
Problem Signature 03: 56b4ec1f
Problem Signature 04: PresentationFramework
Problem Signature 05: 4.6.1055.0
Problem Signature 06: 563c1d45
Problem Signature 07: 2b2
Problem Signature 08: 1f
Problem Signature 09: System.IO.FileNotFoundException
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 16393
Additional Information 1: 606b
Additional Information 2: 606b84565581a859e255082e8c26873f
Additional Information 3: b65d
Additional Information 4: b65d002781916f6e03629076df52d46e


#16

Hi kolasani. Sorry to hear you’re having trouble. The error message you reported is a bit strange. Can you review this thread and see if this fixes any of your problems (http://discourse.monolith.zone/t/things-to-check-if-monolith-isnt-working/45).


#17

I’ve noticed that all of your links to the C++ install are broken. It appears that Microsoft has changed the download page.